> > > How to Figure Out if Clarify Code is 4.6+ or Earlier

How to Figure Out if Clarify Code is 4.6+ or Earlier

19th March 2017

Below is a sample Cleo Clarify Project that we are reviewing to see if the end-user has updated the project, package and source objects were upgraded to version 4.6+

Cleo Clarify Project, Pakackage, Objects and MANIFEST.MF

Before 4.6 Upgrade

We will review the MANIFEST.MF file to see  Bundle-RequiredExecutionEnvironment value is JavaSE-1.6  

Manifest-Version: 1.0
Bundle-ManifestVersion: 2
Bundle-Name: com.escalade.core
Bundle-Vendor: Cleo
Bundle-Version: 1.0.0.qualifier
Eclipse-BundleShape: dir
Bundle-SymbolicName: com.escalade.core; singleton:=true
Bundle-ActivationPolicy: lazy
Require-Bundle: com.extol.ebi.ebiprojectdependencies;bundle-version=“[4.5.0,5.0.0)”,
com.extol.professional.services.toolkit;bundle-version=“1.0.0”
Bundle-RequiredExecutionEnvironment: JavaSE-1.6

The set-up above tells us the the code base is less than 4.6

After 4.6 Upgrade

Manifest-Version: 1.0
Require-Bundle: com.extol.ebi.ebiprojectdependencies;bundle-version=“[
4.5.0,5.0.0)”
Bundle-Vendor: Cleo
Bundle-ActivationPolicy: lazy
Eclipse-BundleShape: dir
Bundle-Version: 1.0.0.qualifier
Bundle-ManifestVersion: 2
Bundle-RequiredExecutionEnvironment: JavaSE-1.7

What tips us off, about being the Clarify project, package and source objects being upgraded to 4.6+ is JavaSE-1.7

Cleo Clarify 4.6 MANIFEST.MF


By: on